Aktuell

   
  

PHP 7 wird zur Pflicht


Mehr als 80% aller Websites (laut Wikipedia) sind mit der Web-Skriptsprache PHP ausgestattet. PHP wurde seit Bestehen laufend weiterentwickelt und so gibt es derzeit viele Websites die auf Basis von vielen verschiedenen PHP-Versionen erstellt wurden.

Diese Skriptsprache wird hauptsächlich zur Erstellung von dynamischen Websites oder Webanwendungen verwendet und wird den Website-Erstellern stets Serverseitig zur Verfügung gestellt.

Jetzt, nach nun über 20 Jahren und vielen PHP-Versionen, stellen die PHP-Entwickler eine komplett überarbeitete Neuversion, PHP 7, zur Verfügung . Mit über 10.000 Fehlerkorrekturen und zahlreichen Neuerungen und Verbesserungen ist dies erstmal eine positive Entwicklung die von Programmierern sehr begrüßt wird.

Allerdings werden durch die General-Neuauflage von PHP alle PHP-Versionen die vor Dezember 2015 erschienen sind, nicht mehr unterstützt. Aus Sicherheitsgründen wird es daher auch serverseitig bald keinen Support mehr geben.

Daher wird auch auf den Servern von happywebsite der Support für alte PHP-Versionen eingestellt.

Das bedeutet, das sämtliche Websites mit PHP-Versionen von vor Dezember 2015, ab Februar 2017 nicht mehr funktionieren werden.

Bei Versionen ab Dezember 2015 bis Juli 2016 ist es nur eine Frage der näheren Zukunft, dass auch diese nicht mehr funktionieren werden.

Da diese Situation nun mal nicht zu ändern ist machen wir aus der Not eine Tugend. Wir schauen nach vorne und bieten ab sofort alle unsere neuen Websites auf Basis von PHP 7 an.

Zudem sind wir in der Lage kostengünstig, alle alten Websites auf PHP 7 umzustellen. Darin unterscheiden wir uns von vielen anderen Website-Anbietern, die auf PHP 7 meist nur eine Antwort haben: Der Kunde braucht eine komplett neue Website.

Eine Happy Website ist zwar auf der Skriptsprache PHP aufgebaut, kann aber nur deshalb überschaubar auf PHP 7 angepasst werden, da sie von happywebsite selbst entwickelt wurde.

Weitere Infos finden Sie in folgenden Artikeln:


Sie haben Fragen zu PHP 7? Gerne stehen wir Ihnen hierfür zur Verfügung.        Kontakt »

background